Payment Service down

Incident Report for Wero

Resolved

This incident has been resolved.
Posted May 28, 2026 - 01:30 CEST

Investigating

We are currently investigating this issue.
Posted May 28, 2026 - 01:29 CEST
This incident affected: E-commerce (Payment Processing, Consent Flow, Advanced Transaction Types, Consumer Protection & Disputes, Notifications) and P2P (Onboarding & Activation, Payments, Core Processing, Identity & Discovery, Notifications).